The Only World-Standard SEO Software

SEO and Internet Marketing Forum
Welcome, Guest ( Login | Register )

How to fix homepage showing up as two different pages
New Topic Add Reply
Page 1 of 1 [ 8 posts ]
Author Message
jooonathan

Newborn

Newborn
Posts: 4
Posted: Sun May 07, 2017 3:56 am

Question:

My site is showing up like this, both in WebSite Auditor and Google Analytics:
site.com/
site.com/index.html

That's a problem, correct? I only have one homepage, but somehow it's showing up twice in these reports, and I imagine to search engines.

Does anyone know how to fix this?

Thanks much.

J

LinkAssistant

User avatar
Site Admin
Posts: 5588
Posted: Fri May 12, 2017 9:57 am

Most probably you have some links on your website that lead to both these pages. So, check your internal links and make sure you have them all pointing to the right version only.

jooonathan

Newborn

Newborn
Posts: 4
Posted: Wed Jun 07, 2017 8:17 am

LinkAssistant wrote:
Most probably you have some links on your website that lead to both these pages. So, check your internal links and make sure you have them all pointing to the right version only.


Thanks very much. Extremely helpful.

Is there an easy way for me to find/check all my links to the index page with WebSite Auditor?

I'm guessing somewhere in my site I must have an external link to "www.site.com" (instead of making everything an internal link to my index.html page) which is causing the problem. How to find that, I don't know.

Sorry if this is a basic question - I'm pretty new to this & my mental hard drive is too full.

Jonathan

LinkAssistant

User avatar
Site Admin
Posts: 5588
Posted: Thu Jun 08, 2017 7:35 am

Yes, you may see the list of pages that have links to your site.com/.

Just switch to the Pages section - then find your site.com/ page and then at the bottom you will see the Links To Page tab that will show all pages that have links to that page:

http://prntscr.com/fhaaj4

jooonathan

Newborn

Newborn
Posts: 4
Posted: Fri Jun 23, 2017 5:19 am

Hi,

Thanks again for the advice. I did see a few links to the other page, and I updated them, and left them alone for several days. Now WebSite Auditor shows no links to the other page.

But the issue is still there.

Both pages show up in Google Analytics. (Screenshot attached, or both pages in showing up in Google Analytics, but with no links in WebSite Auditor.)

WebSite Auditor also gives me errors as having Duplicate meta descriptions and Duplicate Titles for both pages. I'm really not sure how to fix this. Maybe something's wrong with my .htaccess or hosting? Not sure where to turn at this point.

Thanks again,

Jonathan

LinkAssistant

User avatar
Site Admin
Posts: 5588
Posted: Wed Jun 28, 2017 1:51 pm

Most probably you have also enabled to search for orphan pages when you created your project. In this case the URL has been found in Google index. Try to rebuild your project once again, but make sure you disable searching for orphan pages:

Image

jooonathan

Newborn

Newborn
Posts: 4
Posted: Thu Jun 29, 2017 6:19 am

Thanks for the advice.

Honestly, my main problem isn't really with Site Auditor. Even if I get Site Auditor working properly, Google still has both site.com and site.com/index.html registered as separate pages, and as far as I can tell, is dinging my SEO as a result. That's the core problem. I feel like I need a way to fix my site, even after I would get Site Auditor working properly. It's so strange.

Thanks again.

Jonathan

LinkAssistant

User avatar
Site Admin
Posts: 5588
Posted: Wed Jul 05, 2017 2:30 pm

You need to make sure that there are no links that point to to the other homepage on your website. Secondly, make a redirect.

also note that search engine indexes are not updated that often, so both your version may show up for some time after you fix all the issues with redirects and links.

Display topics from previous:    Sort by    
New Topic Add Reply
Page 1 of 1 [ 8 posts ]
All times are UTC

Jump to:  


cron