The Only World-Standard SEO Software

SEO and Internet Marketing Forum
Welcome, Guest ( Login | Register )

Backlink on SEOSPY but nothing on the page ?
New Topic Add Reply
Page 1 of 1 [ 2 posts ]
Author Message
ARK

Newborn

Newborn
Posts: 1
Posted: Thu Sep 24, 2015 4:42 pm

Hello,
Here is my question, maybe someone has the answer ?

on my SEO SPYglass analyse, there is a backlink result that appear, but when i clic on the link to go to see the website, there is not my website adress on it, even not on the html code.

Do someone know why ?

Best regards !

LinkAssistant

User avatar
Site Admin
Posts: 5588
Posted: Fri Sep 25, 2015 12:58 pm

Quote:
on my SEO SPYglass analyse, there is a backlink result that appear, but when i clic on the link to go to see the website, there is not my website adress on it, even not on the html code.


Let us please explain how it works: there`s a crawler that gathers all the pages and links on the web and indexes them once in several months, then SEO SpyGlass is taking this information from index, but there`s a chance that within that 2-3 months time span the information might have partially become outdated as any link might have been removed or the page might be down.

To get accurate realistic results you need to click the 'Update factors' button and select the 'Page info' factor so that the information would get updated.

Display topics from previous:    Sort by    
New Topic Add Reply
Page 1 of 1 [ 2 posts ]
All times are UTC

Jump to:  


cron